Jump to content

Not able to take control from ai in Pendolino/Dragon 2 if "Disable ETCS" settings is turned on

Recommended Posts

When you have the "Disable ETCS" settings turned on and then try to take control from the AI in the Pendolino or the Dragon 2 train. You will not be able to take control and the button will flash for a second.

The workaround for this is, After jumping on a train, Turn off the "Disable ETCS" setting, and let it automatically set the ETCS system of the train, then you can turn it back off and take control of the train if you wish.


  • I agree 1
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

Terms of Use Privacy Policy